Back to overview
Resolved

Huma is currently experiencing some slowness and instability.

Aug 20, 2026 at 11:00am UTC
Affected services
Huma Web
Huma API

Resolved
Sep 1, 2026 at 11:31am UTC

Huma has remained stable for a sustained period, and we consider the system to be back to normal. We will continue to monitor the system closely to ensure it remains stable.

Updated
Sep 1, 2026 at 9:40am UTC

We believe we have identified the root cause of the slowness and instability and have deployed a fix.

We are closely monitoring the system to assess the impact of the fix and will provide another update once we have confirmed that Huma is stable.

Updated
Sep 1, 2026 at 6:00am UTC

Huma is currently experiencing slowness and instability. We are working hard to identify the cause of the issue and resolve it as quickly as possible.

Updated
Aug 20, 2026 at 12:04pm UTC

Huma is back to normal, but we will continue monitoring the situation.

Updated
Aug 20, 2026 at 11:44am UTC

Still some slowness and instability.

Updated
Aug 20, 2026 at 11:26am UTC

Huma is back to normal, but we will continue monitoring the situation.

Created
Aug 20, 2026 at 11:00am UTC

Huma is currently experiencing some slowness and instability. We are working to resolve this.