Service instability
Resolved
Jan 15, 2026 at 01:52pm UTC
The sub-provider has provided information on the root cause and their steps for preventing recurrence.
Affected services
Updated
Jan 13, 2026 at 09:00am UTC
A solution to the issue causing instability has been implemented and we are now monitoring the results. The services should be fully available again.
Affected services
Updated
Jan 13, 2026 at 08:20am UTC
The issue causing outages in our sub-provider has been identified, and a solution to restore service is being actively implemented.
Affected services
Created
Jan 13, 2026 at 06:24am UTC
Huma is currently experiencing some slowness and instability due to an issue with one of our service providers. We are working with them to resolve this.
Affected services