Back to overview
Downtime

Service availability is unreliable due to issues with a sub-provider

Apr 10 at 11:09am CEST
Affected services
Huma Web
Huma API

Resolved
Apr 10 at 11:35am CEST

Service has been restored. The issue is still being investigated. We will post updates here if Huma stands to be affected further.

Created
Apr 10 at 11:09am CEST

We are experiencing issues with our subscription management sub-provider, Recurly. This leads to Huma being intermittently unavailable. See https://status.recurly.com/ for their status.