Back to overview
Downtime
Service is unavailable
Mar 09 at 11:07am CET
Affected services
Huma Web
Huma API
Resolved
Mar 09 at 11:32am CET
We have identified and resolved the issue. The service is now available again.
Affected services
Created
Mar 09 at 11:07am CET
Huma is currently unavailable due to an issue with one of our sub-providers. We are working with them to try to restore access as soon as possible.
Affected services