Service is unavailable
Resolved
Jul 18 at 10:04am CEST
The subprovider issue has been resolved, and full service functionality is restored.
Affected services
Updated
Jul 18 at 09:11am CEST
We have a workaround for our subprovider issues, and are in the process of deploying it. Service will resume within a few minutes.
You will be unable to update your subsription until our subprovider resolves the underlying issue, and we are continuing to follow up with them, but all other functionality is available.
Affected services
Created
Jul 18 at 05:44am CEST
Huma is currently unavailable due to an issue with one of our sub-providers. We are working with them to try to restore access as soon as possible.
Affected services