Back to overview
Degraded
Service instability
Feb 24 at 11:41am CET
Affected services
Huma Web
Huma API
Resolved
Feb 24 at 12:01pm CET
Issue has been resolved
Affected services
Updated
Feb 24 at 11:50am CET
The issue has been mostly fixed, we are monitoring.
Affected services
Created
Feb 24 at 11:41am CET
Huma is currently experiencing some slowness and instability due to an issue in our subscription and billing subprovider impacting our ability to verify customer subscription statuses.
We are working to resolve this.
Affected services