Back to overview
Degraded
Service instability
Dec 11 at 01:27pm CET
Affected services
Huma Web
Resolved
Dec 11 at 01:57pm CET
The issue appears to be resolved, we are monitoring for stability.
Affected services
Created
Dec 11 at 01:27pm CET
Huma is currently experiencing some slowness and instability due to an issue with one of our service providers. We are working to resolve this.
Affected services